SMART support for Adaptec JBOD

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

SMART support for Adaptec JBOD

Deepak SysAdm
Hi guys,

I've smartd configured for the drives in the RAID unit on Adaptec Controller (using /dev/sg device) and they're working fine. However, I can't find out the SMART status of one drive on the controller which is not part of a RAID unit, but setup as JBOD. The error message is given below:

smartctl -a -d scsi /dev/sg1
smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Device: Adaptec  JBOD1            Version: V1.0
scsiModePageOffset: response length too short, resp_len=4 offset=4 bd_len=0
>> Terminate command early due to bad response to IEC mode page
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

-----

whereas it's working fine for /dev/sg2 (1st drive on the RAID1 unit)

Device: SEAGATE  ST373455SS       Version: 0002
Serial number: 3LQ19RCB000098015TFW
Device type: disk
Transport protocol: SAS
Local Time is: Tue Apr  7 10:10:21 2009 CDT
Device supports SMART and is Enabled
Temperature Warning Enabled
SMART Health Status: OK

------------------------

I've already tried the '-T permissive' option, but that didn't help. Is there any way to get the JBOD drive working with smartd? Thanks in advance!

Regards,
Deepak

------------------------------------------------------------------------------
This SF.net email is sponsored by:
High Quality Requirements in a Collaborative Environment.
Download a free trial of Rational Requirements Composer Now!
http://p.sf.net/sfu/www-ibm-com
_______________________________________________
Smartmontools-support mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/smartmontools-support