Unrecognised USB Bridge Device

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Unrecognised USB Bridge Device

Colin Payne
Hi,

I am using a USB to mSATA SSD board “Pi-102” manufactured by Lycom (http://www.lycom.com.tw/Pi-102.htm)

The Pi-102's USB bridge chip is upd720231A manufactured by Renesas (https://www.renesas.com/en-eu/products/usb-assp/upd720231a.html)

I’m running Smartmontools on a Raspberry Pi 3, and when I run:

$ sudo smartctl --all /dev/sda -s on

…I expected to see a detailed report of the drive data, but instead I got:

/dev/sda: Unknown USB bridge [0x045b:0x0229 (0x000)]
Please specify device type with the -d option.

Use smartctl -h to get a usage summary

Reading through the Smartmontools support archive, it appears that the Renesas upd720231A USB bridge is listed, but with a different idVendor:idProduct (0x045b:0x022a):

https://sourceforge.net/p/smartmontools/mailman/message/34792018/

…and in a changeset on the smartmontools.org site: https://www.smartmontools.org/changeset/4303 

How do I go about getting the USB bridge I’m using added so that I can use Smartmontools for SSDs connected via the Lycom Pi-102, please?

Many thanks,

Colin


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Smartmontools-support mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/smartmontools-support